How to run Tingbot-os on Raspbian.

  • I have the latest version of Raspbian and wondering how to run the Thingbot on it. I am missing some guide in the docs section. I stuck on dpkg -i tingbot-os.deb which needs some additional dependencies, eg.

    tingbot-os depends on libsdl1.2debian (= 1.2.15-5); however:
    Version of libsdl1.2debian:armhf on system is 1.2.15-10+rpi1.

    What kind of configuration or dependencies are needed to have it running there?

  • Core team

    Hi legoland

    Normally we recommend using one of the pre-made images disk.img, which is Raspbian Jessie underneath. (these are available here

    However if you'd like to install Tingbot OS on an existing Raspbian install, it may be possible. We lock to a specific version of libsdl because of a bug that appeared in later versions. That version of SDL is here: . Download and dpkg -i that, and it should resolve the above error.

    Cheers! Joe

Log in to reply

Looks like your connection to How to run Tingbot-os on Raspbian. was lost, please wait while we try to reconnect.